Upgrade python2.7 di Debian Squeeze

Uh-oh, versi interpreter python di repo Debian 6.0 masih versi 2.6.6, sedangkan saya perlu versi 2.7 agar dapat menggunakan SDK Google AppEngine dengan baik. Karena python2.7 adanya di repo testing, baris berikut perlu ditambahkan di /etc/apt/sources.list:

deb http://kambing.ui.ac.id/debian testing main contrib non-free

Lalu perbaharui daftar paket dari repo dan pasang python2.7

# apt-get update
# apt-get install python2.7

Sekalian buat 2.7 menjadi default runtime
# update-alternatives --install /usr/bin/python python /usr/bin/python2.7 10